Token redemption issue on MypaymentVault website

Service disruption Onbe Recipient Tools Mypaymentvault - Recipient Website
2025-09-17 07:25 CDT · 1 hour, 58 minutes, 1 second

Updates

Resolved

The issue affecting the token redemption on Mypaymentvault has been resolved as of 10:13 AM ET. New token redemptions are processing as expected. A small number of tokens affected during the incident are being manually reconciled.

Thank you for your patience, and we apologize for any inconvenience this may have caused.

September 17, 2025 · 09:20 CDT
Investigating

We continue to investigate the token redemption issues on Mypaymentvault and will provide an update as soon as possible when available.

September 17, 2025 · 08:30 CDT
Investigating

We are currently experiencing an issue affecting Mypaymentvault website. This may impact users and clients attempting to perform redemptions or issue tokens.

Our technical team is actively investigating the root cause. We will share updates as they become available and notify you as soon as the issue is resolved.

September 17, 2025 · 07:25 CDT

← Back